BAPI_PO_CREATE1 setzt netto Preis auf 0 obwohl vorhanden

Die Frage ist als "gelöst" markiert. Den entsprechend Beitrag findest du hier.

Alles rund um die Sprache ABAP®: Funktionsbausteine, Listen, ALV
3 Beiträge • Seite 1 von 1
3 Beiträge Seite 1 von 1

BAPI_PO_CREATE1 setzt netto Preis auf 0 obwohl vorhanden

Beitrag von elgreco (ForumUser / 1 / 0 / 0 ) »
Hallo,

ich habe folgendes Problem:
Ich übergebe einen Nettopreis von 10 EUR. Wenn man aber über diesen BAPI durchgeht, wird der Preis auf 0 gesetzt und man bekommt folgende Fehlermeldung:
"Der Nettopreis muß größer 0 sein".

ich füttere folgende Tabellen:
CALL FUNCTION 'BAPI_PO_CREATE1'
EXPORTING
poheader = ls_poheader
poheaderx = ls_poheaderx
no_messaging = 'X'
IMPORTING
exppurchaseorder = mv_new_po
expheader = ms_expheader
exppoexpimpheader = ms_exppoexpimpheader
TABLES
return = mt_return
poitem = lt_po_item
poitemx = lt_po_itemx
poaccount = lt_po_account
poaccountx = lt_po_accountx
poschedule = lt_po_schedule
poschedulex = lt_po_schedulex
pocondheader = lt_po_cond_header
pocondheaderx = lt_po_cond_headerx
pocond = lt_po_cond
pocondx = lt_po_condx.


In PO_ITEM, POCOND usw. überall bei dem ein Nettopreis angegeben werden muss steht 10 EUR drin.
Was mir aber selber aufgefallen ist, ist dass POCOND nach dem man über den BAPI gelaufen ist drei Zeilen bekommt.

BEVOR man über den BAPI läuft:
Eine Zeile mit COND_TYPE PB00 und Preis 10 EUR etc.

NACHDEM man über den BAPI läuft:
Eine Zeile mit COND_TYPE PB00 und Preis 0 EUR.
Eine Zeile mit COND_TYPE NAVS und Preis 0 EUR.
Eine Zeile mit COND_TYPE SKT0 und Preis - 3 EUR.

Hattet ihr schon mal sowas?

Gruß

gesponsert
Stellenangebote auf ABAPforum.com schalten
kostenfrei für Ausbildungsberufe und Werksstudenten


Re: BAPI_PO_CREATE1 setzt netto Preis auf 0 obwohl vorhanden

Beitrag von wreichelt (Top Expert / 1036 / 29 / 188 ) »
Hallo,

die Preise könnten aus dem EK Infosatz kommen
2115641 - BAPI_PO_CREATE1: price overwritten from info record

Gruß Wolfgang

Re: BAPI_PO_CREATE1 setzt netto Preis auf 0 obwohl vorhanden

Beitrag von PeterPaletti (Specialist / 339 / 29 / 96 ) »
Wieso Nettopreis in PO_ITEM? Ich schreibe nur POCOND und es funktioniert.

Seite 1 von 1

Vergleichbare Themen

2
Antw.
2838
Views
Netto preis ermitteln
von ZABAP » 30.08.2004 14:58 • Verfasst in ABAP® für Anfänger
1
Antw.
2320
Views
Problem mit dem Netto Gewicht
von Enja » 20.02.2005 18:46 • Verfasst in ABAP® für Anfänger
3
Antw.
1830
Views
Wie setzt man das Pragma ##NO_HANDLER ein?
von DeathAndPain » 27.05.2020 16:24 • Verfasst in ABAP® für Anfänger
5
Antw.
715
Views
DB-Update setzt kein Subrc
von RIG » 29.07.2021 12:10 • Verfasst in ABAP® für Anfänger
3
Antw.
3121
Views
refresh_table_display setzt aktuelle zelle um :(
von SwordMaster » 13.10.2005 14:55 • Verfasst in Dialogprogrammierung

Über diesen Beitrag



Die Frage ist als "gelöst" markiert. Den entsprechend Beitrag findest du hier.

Unterstütze die Community und teile den Beitrag für mehr Leser und Austausch

Aktuelle Forenbeiträge

Problem mit Custom-Dynpro in VL02N
vor einer Stunde von Xilukarim gelöst 2 / 32

Newsletter Anmeldung

Keine Beiträge verpassen! Wöchentlich versenden wir lesenwerte Beiträge aus unserer Community.
Die letzte Ausgabe findest du hier.
Details zum Versandverfahren und zu Ihren Widerrufsmöglichkeiten findest du in unserer Datenschutzerklärung.